Radius Networks

DST Root CA X3 Expiration
Resolved

This incident has been addressed, any further issues please contact Radius Networks Support support@radiusnetworks.com.

Sat, Oct 2, 2021, 01:17 PM
(3 years ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been addressed, any further issues please contact Radius Networks Support support@radiusnetworks.com.

Sat, Oct 2, 2021, 01:17 PM

Identified

Due to planned change with the root certificate from our CA (Let's Encrypt) older clients making requests to the Flybuy system may receive errors. If you see errors related to certificate authenticity or establishing secure connections please contact your customer success representative or Radius Networks Support support@radiusnetworks.com.

For more information on Let's Encrypt's certificate changes, their expiration, and actions needed, see details from Let's Encrypt:

  • https://letsencrypt.org/docs/dst-root-ca-x3-expiration-september-2021/

  • https://letsencrypt.org/2020/12/21/extending-android-compatibility.html

  • https://community.letsencrypt.org/t/production-chain-changes/150739

  • https://community.letsencrypt.org/t/openssl-client-compatibility-changes-for-let-s-encrypt-certificates/143816

Thu, Sep 30, 2021, 10:59 PM(1 day earlier)