Resolved
This incident has been resolved.
Monitoring
Latency has dropped and our monitoring shows traffic is nominal. We are continuing to monitor.
Investigating
Due to an issue with our upstream provider we are experiencing an additional latency and are currently investigating the issue.