Resolved
This incident has been resolved.
Monitoring
Mitigations have been implemented and we are monitoring the status of the system.
Investigating
We are implementing mitigations and continuing to investigate the issu.e
Investigating
We are continuing to investigate this issue.
Investigating
We are continuing to investigate this issue.
Investigating
The Flybuy system is experiencing a degradation in service. The engineering team has identified the issue and is investigating.