Resolved
The issue has been resolved. All systems are operational and healthy.
Monitoring
Mitigations have been implemented. We are no longer experiencing a degraded level of service. The incident response team is continuing to monitor the situation.
Identified
The source of the ETA calculation degradation has been identified, and teams are working on mitigation measures.
Investigating
We are currently investigating an issue affecting ETA calculation accuracy for some orders. ETA updates may be delayed or inconsistent while the issue is being addressed.